Install PCRE 8 on Ubuntu 10.04 LTS

Friday, November 2nd, 2012 at 0142

You might find yourself wanting to install Bug Genie, or some other such newfangled toy onto Ubuntu 10.04 “Lucid”.

You might find yourself stonewalled at the suggestion that your PCRE version (7.8) doesn’t meet the minimum requirements of 8.x

You might then have found yourself here.

The solution is thankfully straightforward. Just add the precise pangolin repo temporarily to your apt sources and install via apt.

sudo nano /etc/apt/sources.list

Comment out all the lines by placing a # at the start of each one. Then add the following to the end:

deb http://archive.ubuntu.com/ubuntu precise main restricted universe multiverse

Ctrl+X then ‘y’ to save from nano, then do:

sudo apt-get update
sudo apt-get install libpcre3

Then go back and restore your apt sources.list to its former state, and run apt-get update again.

2 Comment for “Install PCRE 8 on Ubuntu 10.04 LTS”

  1. Kaore Said this on

    I got a bunch of errors when attempting to install that way:

    gnome-icon-theme: Breaks: gnome-games (< 1:2.30.2-1) but 1:2.30.0-0ubuntu6 is to be installed
    libglib2.0-0: Breaks: gnome-control-center (< 1:3) but 1:2.30.1-0ubuntu2 is to be installed
    Breaks: gvfs (< 1.8) but 1.6.1-0ubuntu1build1 is to be installed
    libpango1.0-0: Breaks: plymouth (< 0.8.2-2ubuntu19) but 0.8.2-2ubuntu2.2 is to be installed
    ppp: Breaks: network-manager (<= 0.8.0.999-1) but 0.8-0ubuntu3.3 is to be installed
    Breaks: network-manager-pptp (<= 0.8.0.999-1) but 0.8-0ubuntu3 is to be installed

  2. Denyerec Said this on

    Hey Kaore, that’s unfortunate. I did it to the server ISO, my guess is you’ve got other packages that are pending updates that are picking up from the updated repo?

Leave a Reply

XHTML: You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>